CVE-2024-21908: tinymce · Cross-site Scripting
Affects tinymceSource CVE Database V5
Not known to be exploited · CVSS 6.1 Medium : upgrade to 5.9.0 when convenient.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 1.0% chance of exploitation in 30 days – higher than 64% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.9.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Jan 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade tinymce/tinymce to 5.9.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
npmtinymce/tinymcepkg:npm/tinymce/tinymceOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade TinyMCE to version 5.9.0 or later, where this vulnerability has been fixed. Since the vulnerability affects versions before 5.9.0, applying the official update is the recommended remediation. No vendor advisory was provided to indicate alternative mitigations or temporary fixes.
Description
TinyMCE versions before 5.9.0 are affected by a stored cross-site scripting vulnerability. An unauthenticated and remote attacker could insert crafted HTML into the editor resulting in arbitrary JavaScript execution in another user's browser.