Skip to main content
VulnerabilityPublished

CVE-2025-14579: Quiz Maker (WordPress plugin) · Cross-Site Scripting (XSS)

Affects Quiz Maker (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 4.8 Medium : upgrade to 6.7.0.89 when convenient.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.7.0.89
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Quiz Maker (WordPress plugin) to 6.7.0.89.

Affected software

ProductAffectedFixed in
Quiz MakerAffected
  • <6.7.0.89
Fixed in
  • 6.7.0.89

AI-suggested

European organizations should immediately verify if they use the Quiz Maker WordPress plugin and identify the installed version. If running a version prior to 6.7.0.89, they should prioritize upgrading to the latest patched version as soon as it becomes available. Until patched, administrators should restrict plugin access to only the most trusted users and consider temporarily disabling the plugin if feasible. Implementing strict role-based access controls (RBAC) to limit the number of users with high privileges can reduce exploitation risk. Additionally, applying Web Application Firewall (WAF) rules that detect and block suspicious script injections in plugin settings fields may provide interim protection. Regularly auditing plugin settings for unexpected or suspicious content can help detect exploitation attempts early. Organizations should also ensure their WordPress core and all plugins are kept up to date and monitor security advisories from plugin developers and WPScan. For multisite setups, extra caution is advised to monitor cross-site contamination and enforce strict user permissions. Finally, educating administrators about the risks of stored XSS and safe plugin configuration practices will help mitigate human error.

Description

CVE-2025-14579 is a medium severity Stored Cross-Site Scripting (XSS) vulnerability in the Quiz Maker WordPress plugin versions before 6.7.0.89. It arises because certain plugin settings are not properly sanitized or escaped, allowing high privilege users such as administrators to inject malicious scripts. This vulnerability can be exploited even when the unfiltered_html capability is disabled, such as in multisite WordPress setups. Exploitation requires high privileges and user interaction, and it can lead to limited confidentiality and integrity impacts, but no direct availability impact. No known exploits are currently reported in the wild. European organizations using affected versions of Quiz Maker, especially those with multisite WordPress deployments, should prioritize patching or mitigating this issue to prevent potential stored XSS attacks that could compromise administrative sessions or site content.

References

Community reviews

Loading reviews…