Skip to main content
VulnerabilityPublished Updated

CVE-2024-22274: VMware vCenter Server · Authenticated Remote-code Execution Vulnerability

Affects VMware vCenter ServerSource CVE Database V5

0
Compare

Public exploit available · CVSS 7.2 High : upgrade to 8.0 U2b or 7.0 U3q as a priority.

Data as of 4 Nov 2026, 00:13 UTC

CVSS 3.1 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (vmware)CVSS 3.17.2
EPSS
2.5% chance of exploitation in 30 days – higher than 84% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CISA SSVC
Exploitation
Proof of concept is public or traded
Automatable
Attackers cannot reliably automate steps 1–4 of the kill chain
Technical impact
Total control over the software or total information disclosure

CISA SSVC assessment, 2024-07-11.

Patch
Available – fixed in 8.0 U2b, 7.0 U3q, 5.1.1
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 21 May 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CISA SSVC: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

Timeline

  1. CVE ID reserved

    by VMware by Broadcom

    , 134 days before disclosure

  2. CVE published

    on cve.org

    , t = 0

  3. CISA SSVC assessment

    proof of concept public

    , 51 days after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA SSVC, the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade VMware to 8.0 U2b or 7.0 U3q (vCenter Server); 5.1.1 (Cloud Foundation (vCenter Server)).

Affected software

ProductAffectedFixed in
VMware vCenter ServerAffected
  • =8.0
  • =7.0
Fixed in
  • 8.0 U2b
  • 7.0 U3q
VMware Cloud Foundation (vCenter Server)Affected
  • >=5.x <5.1.1
  • =>=4.0.0 <5.0.0
Fixed in
  • 5.1.1

AI-suggested

Apply the official patches provided by VMware by upgrading to versions 5.1.1, 7.0 U3q, or 8.0 U2b or later. Since fixed versions are available, remediation should be performed promptly to mitigate the risk. No additional vendor advisory states otherwise.

Description

The vCenter Server contains an authenticated remote code execution vulnerability. A malicious actor with administrative privileges on the vCenter appliance shell may exploit this issue to run arbitrary commands on the underlying operating system.

References

Community reviews

Loading reviews…