Skip to main content
VulnerabilityPublished Updated

CVE-2024-37081: VMware vCenter Server · Local Privilege Escalation Vulnerability

Affects VMware vCenter ServerSource CVE Database V5

0
Compare

Public exploit available (Metasploit) · CVSS 7.8 High : upgrade to 8.0 U2d or 7.0 U3r as a priority.

Data as of 4 Nov 2026, 00:28 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (vmware)CVSS 3.17.8
EPSS
4.9% chance of exploitation in 30 days – higher than 92% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CISA SSVC
Exploitation
Proof of concept is public or traded
Automatable
Attackers cannot reliably automate steps 1–4 of the kill chain
Technical impact
Total control over the software or total information disclosure

CISA SSVC assessment, 2024-07-11.

Patch
Available – fixed in 8.0 U2d, 7.0 U3r
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 18 Jun 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    1 Metasploit module

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

Timeline

  1. CVE ID reserved

    by VMware by Broadcom

    , 15 days before disclosure

  2. CVE published

    on cve.org

    , t = 0

  3. CISA SSVC assessment

    proof of concept public

    , 23 days after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade VMware vCenter Server to 8.0 U2d or 7.0 U3r.

Affected software

ProductAffectedFixed in
VMware vCenter ServerAffected
  • =8.0
  • =7.0
Fixed in
  • 8.0 U2d
  • 7.0 U3r
VMware Cloud FoundationAffected
  • =>=5.0.0 <6.0.0
  • =>=4.0.0 <5.0.0
Fixed in–

AI-suggested

Apply the official patches provided by VMware by upgrading to vCenter Server versions 7.0 U3r or 8.0 U2d or later. These versions contain fixes for the sudo misconfiguration vulnerabilities. Since this is not a cloud service, administrators must manually update affected appliances to remediate the issue.

Description

The vCenter Server contains multiple local privilege escalation vulnerabilities due to misconfiguration of sudo. An authenticated local user with non-administrative privileges may exploit these issues to elevate privileges to root on vCenter Server Appliance.

References

Community reviews

Loading reviews…