CVE-2024-22451: Dell Peripheral Manager · Uncontrolled Search Path Element
Affects Dell Peripheral ManagerSource CVE Database V5
Not known to be exploited · CVSS 6.7 Medium : upgrade to 1.7.3 or later when convenient.
Data as of 30 Oct 2026, 20:25 UTC
- EPSS
- 0.09% chance of exploitation in 30 days – higher than 0% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.7.3 or later, 1.5.1
CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 16 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Peripheral Manager to 1.7.3 or later; dell/peripheral-manager to 1.5.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| DellPeripheral Manager | Affected
| Fixed in
|
Delldell/peripheral-managerpkg:rpm/dell/peripheral-managerOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, users should avoid running untrusted executables and limit local user access where possible.
Description
Dell Peripheral Manager, versions from 1.5.1 to 1.7.2, contain an uncontrolled search path element vulnerability. An attacker could potentially exploit this vulnerability through preloading malicious executable, leading to arbitrary code execution.