CVE-2024-25723: zenml · Improper Access Control
Affects zenmlSource CVE Database V5
Not known to be exploited · public detection template (Nuclei) · 70% EPSS · CVSS 8.8 High : upgrade to 0.46.7 as a priority.
Data as of 26 Oct 2026, 09:15 UTC
- EPSS
- 70.7% chance of exploitation in 30 days – higher than 99% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.46.7
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 27 Feb 2024
Detectable: evidence found.
nuclei template: ZenML ZenML Server - Improper Authentication
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade zenml to 0.46.7.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
PyPIzenmlpkg:pypi/zenmlOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
To mitigate this vulnerability, organizations should immediately upgrade ZenML Server to one of the patched versions: 0.42.2, 0.43.1, 0.44.4, or preferably 0.46.7 or later. Additionally, restrict access to the ZenML Server API endpoints using network segmentation and firewall rules to limit exposure to trusted users and systems only. Implement strong authentication and authorization mechanisms around the API, ensuring that only properly authenticated and authorized users can perform sensitive operations such as user activation or password resets. Regularly audit API access logs for suspicious activity. If upgrading is not immediately feasible, consider disabling or restricting the vulnerable endpoint temporarily. Finally, integrate ZenML Server into a broader security monitoring and incident response framework to detect and respond to potential exploitation attempts.
Description
ZenML Server in the ZenML machine learning package before 0.46.7 for Python allows remote privilege escalation because the /api/v1/users/{user_name_or_id}/activate REST API endpoint allows access on the basis of a valid username along with a new password in the request body. These are also patched versions: 0.44.4, 0.43.1, and 0.42.2.
References
- github.com/zenml-io/zenml (opens in a new tab)
- zenml.io/blog/critical-security-update-for-zenml-users (opens in a new tab)
- github.com/zenml-io/zenml/compare/0.44.3...0.44.4 (opens in a new tab)
- github.com/zenml-io/zenml/compare/0.43.0...0.43.1 (opens in a new tab)
- github.com/zenml-io/zenml/compare/0.42.1...0.42.2 (opens in a new tab)