CVE-2024-27842: Apple macOS · An app may be able to execute arbitrary code with kernel privileges
Affects Apple macOSSource CVE Database V5
Not known to be exploited · CVSS 8.1 High.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 13 May 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apple macOS | Affected
| Fixed in– |
AI-suggested
Apple has released an official fix for this vulnerability in macOS Sonoma 14.5. Users and administrators should apply this update promptly to remediate the issue. No additional mitigation steps are indicated by the vendor advisory beyond updating to the fixed version.
Description
CVE-2024-27842 is a high-severity vulnerability in Apple macOS that allows a local app to execute arbitrary code with kernel privileges due to an out-of-bounds write issue. This vulnerability affects macOS versions prior to Sonoma 14.5 and was addressed by Apple through improved input validation and memory handling. Exploitation could lead to complete system compromise with kernel-level access. Apple released macOS Sonoma 14.5 on May 13, 2024, which includes the official fix for this issue. There are no known exploits in the wild at this time. Users are advised to update to macOS Sonoma 14.5 to remediate this vulnerability.