Skip to main content
VulnerabilityPublished Updated

CVE-2024-29644: dcat-admin · Cross-site Scripting

Affects dcat-adminSource CVE Database V5

0

Not known to be exploited · CVSS 6.1 Medium : upgrade to 2.1.4 when convenient.

Data as of 26 Oct 2026, 11:07 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.1.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Mar 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade jqhph/dcat-admin to 2.1.4.

Affected software

ProductAffectedFixed in
GitHubjqhph/dcat-adminpkg:github/jqhph/dcat-adminOther threatsAffected
  • <2.1.4
Fixed in
  • 2.1.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, users should exercise caution with untrusted input and consider implementing temporary input sanitization or filtering on the login box to mitigate script injection risks.

Description

Cross Site Scripting vulnerability in dcat-admin v.2.1.3 and before allows a remote attacker to execute arbitrary code via a crafted script to the user login box.

References

Community reviews

Loading reviews…