CVE-2024-30260: nodejs undici · Improper Authorization
Affects nodejs undiciSource CVE Database V5
Not known to be exploited · CVSS 3.9 Low : upgrade to 5.28.4 when convenient.
Data as of 26 Oct 2026, 08:30 UTC
- EPSS
- 0.7% chance of exploitation in 30 days – higher than 54% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.28.4
CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 4 Apr 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade nodejs undici to 5.28.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| nodejs undici | Affected
| Fixed in
|
AI-suggested
European organizations should prioritize upgrading Undici to versions 5.28.4 or later, or 6.11.1 or later, where the vulnerability is patched. Code audits should be conducted to identify usage of undici.request() and ensure that Authorization and Proxy-Authorization headers are not inadvertently reused or leaked. Implement strict input validation and header management policies within Node.js applications to prevent unauthorized header propagation. Employ runtime monitoring and logging to detect anomalous usage patterns of HTTP client libraries. In environments where upgrading is not immediately feasible, consider implementing network-level controls to restrict access to vulnerable services and enforce strict authentication and authorization policies. Additionally, educate developers about secure usage patterns of HTTP clients and the importance of consistent header handling. Regularly review dependencies and apply security patches promptly as part of a robust software supply chain management process.
Description
Undici is an HTTP/1.1 client, written from scratch for Node.js. Undici cleared Authorization and Proxy-Authorization headers for `fetch()`, but did not clear them for `undici.request()`. This vulnerability was patched in version(s) 5.28.4 and 6.11.1.
References
- github.com/nodejs/undici/security/advisories/GHSA-m4v8-wqvr-p9f7 (opens in a new tab)
- github.com/nodejs/undici/commit/64e3402da4e032e68de46acb52800c9a06aaea3f (opens in a new tab)
- github.com/nodejs/undici/commit/6805746680d27a5369d7fb67bc05f95a28247d75 (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/P6Q4RGETHVYVHDIQGTJGU5AV6NJEI67E/ (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/HQVHWAS6WDXXIU7F72XI55VZ2LTZUB33/ (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/NC3V3HFZ5MOJRZDY5ZELL6REIRSPFROJ/ (opens in a new tab)
- security.netapp.com/advisory/ntap-20240905-0008/ (opens in a new tab)