CVE-2024-31228: redis · Uncontrolled Recursion
Affects redisSource GCVE Database
Not known to be exploited · CVSS 5.5 Medium · fixed in 7.4.1 : update redis when convenient.
Data as of 30 Oct 2026, 02:17 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 5.5 |
|---|
- Patch
- Available – fixed in 7.4.1, 7.2.6, 6.2.16
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 7 Oct 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade redis to 7.4.1, 7.2.6 or 6.2.16.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| redis redis | Affected
| Fixed in
|
AI-suggested
Upgrade Redis to version 6.2.16, 7.2.6, or 7.4.1 or later to remediate this vulnerability. There are no known workarounds. Users should apply the official fixes provided by Redis.
Description
CVE-2024-31228 is a vulnerability in Redis where authenticated users can cause a denial-of-service by triggering uncontrolled recursion through specially crafted long string match patterns on commands like KEYS, SCAN, PSUBSCRIBE, FUNCTION LIST, COMMAND LIST, and ACL definitions. This leads to stack overflow and process crash. The issue is fixed in Redis versions 6.2.16, 7.2.6, and 7.4.1. No workarounds are known, so upgrading is recommended.