Skip to main content
CVE-2024-34443VulnerabilityPublished Updated

CVE-2024-34443: Slider Revolution (WordPress plugin) · XSS or 'Cross-site Scripting'

Affects Slider Revolution (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 5.9 Medium : upgrade to 6.7.11 when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.7.11
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Jun 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade Slider Revolution (WordPress plugin) to 6.7.11.

Affected software

ProductAffectedFixed in
ThemePunch OHG Slider RevolutionAffected
  • <6.7.11
Fixed in
  • 6.7.11

AI-suggested

If you cannot patch yet, users should restrict access to trusted administrators and limit exposure to untrusted inputs. Monitor for vendor updates regarding patches or official mitigations.

Description

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in ThemePunch OHG Slider Revolution allows Stored XSS.This issue affects Slider Revolution: from n/a before 6.7.11.

References

Community reviews

Loading reviews…