Skip to main content
VulnerabilityPublished Updated

CVE-2024-37535: vte · Uncontrolled Resource Consumption

Affects vteSource CVE Database V5

0

Mentioned vulnerabilities

Not known to be exploited · CVSS 4.4 Medium : upgrade to 0.76.3 when convenient.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
4.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 14% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.76.3
CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Jun 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade gnome/vte to 0.76.3.

Affected software

ProductAffectedFixed in
GitHubgnome/vtepkg:github/gnome/vteOther threatsAffected
  • <0.76.3
Fixed in
  • 0.76.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2024-37535, organizations should: 1) Upgrade GNOME VTE to version 0.76.3 or later once patches are officially released to address the vulnerability. 2) Restrict local high-privilege access to trusted users only, minimizing the risk of exploitation by limiting who can execute terminal commands. 3) Monitor system resource usage for unusual memory consumption patterns in terminal emulator processes, which could indicate attempted exploitation. 4) Implement strict access controls and auditing on systems running GNOME terminal emulators to detect and respond to suspicious activities promptly. 5) Consider using alternative terminal emulators or sandboxing techniques to isolate vulnerable components if immediate patching is not feasible. 6) Educate system administrators and users about the risks of local privilege escalation and the importance of maintaining updated software. These steps go beyond generic advice by focusing on controlling local access, monitoring resource usage, and preparing for incident response related to denial of service conditions.

Description

GNOME VTE before 0.76.3 allows an attacker to cause a denial of service (memory consumption) via a window resize escape sequence, a related issue to CVE-2000-0476.

References

Community reviews

Loading reviews…