CVE-2024-38632: Linux kernel · vfio/pci: fix potential memory leak in vfio_intx_enable()
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 5.5 Medium · fixed in 5.15.0-1073.79~20.04.1 : update Linux kernel when convenient.
Data as of 28 Oct 2026, 11:12 UTC
- Patch
- Available – fixed in 5.15.0-1073.79~20.04.1, 5.15.0-1078.87~20.04.1, 5.15.0-1072.80~20.04.1 +45
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 21 Jun 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
- ubuntu.com/security/notices/USN-6999-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7004-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7005-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7008-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7005-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-6999-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7029-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7166-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7166-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7166-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-7186-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7186-2 (opens in a new tab)
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-ibmpkg:deb/ubuntu/linux-ibm?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and has been released in multiple linux-aws kernel versions including 5.15.0-1073.79~20.04.1 and later. Users should update affected Linux kernel versions to these fixed releases to remediate the vulnerability. No additional mitigation actions are required beyond applying the official fixes.
Description
A potential memory leak vulnerability was identified and fixed in the Linux kernel's vfio/pci subsystem within the vfio_intx_enable() function. The issue occurs if the vfio_irq_ctx_alloc() call fails, leading to a memory leak of the 'name' resource. This vulnerability affects multiple versions of the linux-aws kernel and has been addressed in several fixed releases. The vulnerability has a medium severity rating with no known exploits in the wild.
References
- ubuntu.com/security/CVE-2024-38632 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2024-38632 (opens in a new tab)
- git.kernel.org/linus/82b951e6fbd31d85ae7f4feb5f00ddd4c5d256e2 (opens in a new tab)
- git.kernel.org/stable/c/0bd22a4966d55f1d2c127a53300d5c2b50152376 (opens in a new tab)
- git.kernel.org/stable/c/35fef97c33f3d3ca0455f9a8e2a3f2c1f8cc9140 (opens in a new tab)
- git.kernel.org/stable/c/82b951e6fbd31d85ae7f4feb5f00ddd4c5d256e2 (opens in a new tab)
- ubuntu.com/security/notices/USN-6999-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7004-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7005-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7008-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7005-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-6999-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7029-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7166-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7166-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7166-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-7186-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7186-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7194-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7166-4 (opens in a new tab)