Skip to main content
VulnerabilityPublished Updated

CVE-2024-39487: Linux kernel · bonding: Fix out-of-bounds read in bond_option_arp_ip_targets_set()

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 7.1 High · fixed in 4.4.0-1137.143 : patch Linux kernel soon.

Data as of 28 Oct 2026, 11:03 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.4.0-1137.143, 4.15.0-1182.197~14.04.1, 4.4.0-260.294~14.04.1 +99
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Jul 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-48.48
Fixed in
  • 6.8.0-48.48
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1018.20
Fixed in
  • 6.8.0-1018.20
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1017.20
Fixed in
  • 6.8.0-1017.20
Ubuntu 24.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1017.19
Fixed in
  • 6.8.0-1017.19
Ubuntu 24.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1013.17
Fixed in
  • 6.8.0-1013.17
Ubuntu 24.04 LTSlinux-gkeoppkg:deb/ubuntu/linux-gkeop?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1002.4
Fixed in
  • 6.8.0-1002.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch fixing this vulnerability is available and should be applied. The fix involves checking the string length before accessing it to prevent out-of-bounds reads. Users should update to the fixed kernel versions listed (e.g., 4.4.0-1137.143, 4.15.0-1182.197~14.04.1) or later. After updating, a system reboot is required. No additional mitigations are indicated by the vendor advisory.

Description

CVE-2024-39487 is a high-severity vulnerability in the Linux kernel bonding driver where an out-of-bounds read occurs in the bond_option_arp_ip_targets_set() function. This happens if the input string is empty, causing the code to read beyond the string boundary. The flaw can lead to a kernel crash (denial of service). A fix is available in multiple Linux kernel versions.

References

Community reviews

Loading reviews…