CVE-2024-41997: warp · Code Injection
Affects warpSource CVE Database V5
Not known to be exploited · CVSS 6.6 Medium : upgrade to 2024.07.18 when convenient.
Data as of 26 Oct 2026, 12:54 UTC
- EPSS
- 1.1% chance of exploitation in 30 days – higher than 67% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2024.07.18
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 14 Oct 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade warpdotdev/warp to 2024.07.18.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubwarpdotdev/warppkg:github/warpdotdev/warpOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
To mitigate this vulnerability, organizations should immediately upgrade Warp Terminal to version 2024.07.18 or later, where the issue has been addressed. Until an upgrade is possible, users should be educated to avoid clicking on untrusted warp:// links, especially those purporting to open Docker subshells. Administrators can consider disabling or restricting the use of custom URI handlers related to Warp Terminal if feasible. Network-level protections such as email filtering and web gateway controls should be enhanced to detect and block phishing attempts containing malicious warp:// links. Endpoint detection and response (EDR) solutions can be tuned to monitor for suspicious command execution originating from Warp Terminal processes. Additionally, applying the principle of least privilege to user accounts can limit the potential damage from exploitation. Regular security awareness training emphasizing the risks of clicking unknown links is critical. Monitoring logs for unusual Docker subshell invocations may help detect attempted exploitation. Finally, organizations should maintain an inventory of Warp Terminal installations and Docker usage to prioritize patching and mitigation efforts.
Description
An issue was discovered in version of Warp Terminal prior to 2024.07.18 (v0.2024.07.16.08.02). A command injection vulnerability exists in the Docker integration functionality. An attacker can create a specially crafted hyperlink using the `warp://action/docker/open_subshell` intent that when clicked by the victim results in command execution on the victim's machine.