CVE-2026-48731: warpdotdev warp · OS Command Injection
Affects warpdotdev warpSource CVE Database V5
Not known to be exploited · CVSS 7.8 High : upgrade to 0.2026.05.13.09.15.stable_01 soon.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 0.8% chance of exploitation in 30 days – higher than 59% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.2026.05.13.09.15.stable_01
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 24 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade warpdotdev warp to 0.2026.05.13.09.15.stable_01.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| warpdotdevwarp | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Warp to version 0.2026.05.06.15.42.stable_01 or later where this vulnerability is fixed. No other official remediation or temporary fixes are documented. Until upgrading, avoid opening untrusted local file paths through the affected external or system-default editor routes to reduce risk.
Description
Warp is an agentic development environment. From 0.2024.02.20.08.01.stable_01 until 0.2026.05.06.15.42.stable_01, Warp contains a command injection issue in the Linux external editor launcher. Warp expanded freedesktop .desktop Exec templates for affected editor integrations and executed the expanded command through a shell. A user who opens an attacker-controlled local file path through an affected external editor or system-default editor route can cause shell syntax embedded in that path to execute as the local user. This vulnerability is fixed in 0.2026.05.06.15.42.stable_01.