CVE-2024-42286: Linux kernel · scsi: qla2xxx: validate nvme_local_port correctly
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 7.5 High · fixed in 5.4.0-1135.145~18.04.1 : patch Linux kernel soon.
Data as of 27 Oct 2026, 03:58 UTC
- Patch
- Available – fixed in 5.4.0-1135.145~18.04.1, 5.4.0-1140.147~18.04.1, 5.4.0-1139.148~18.04.1 +75
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 17 Aug 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
- ubuntu.com/security/notices/USN-7088-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7088-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7088-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-7088-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-7100-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7100-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7088-5 (opens in a new tab)
- ubuntu.com/security/notices/USN-7119-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7123-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7144-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7154-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7155-1 (opens in a new tab)
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-gkeoppkg:deb/ubuntu/linux-gkeop?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and has been released in multiple Linux kernel versions including 5.4.0-1135.145~18.04.1 and later. Users should update their Linux kernel to one of the fixed versions provided by their distribution, such as the Ubuntu security updates for 18.04 LTS and 20.04 LTS. No additional mitigation is required once the system is updated.
Description
A vulnerability in the Linux kernel's qla2xxx SCSI driver related to improper validation of nvme_local_port could cause a kernel crash due to a NULL pointer dereference. This issue occurs when the driver load fails with an error registering the local port, leading to a kernel BUG. The flaw has been fixed in several Linux kernel versions including updates for Ubuntu 18.04 and 20.04 LTS.
References
- ubuntu.com/security/CVE-2024-42286 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2024-42286 (opens in a new tab)
- git.kernel.org/linus/eb1d4ce2609584eeb7694866f34d4b213caa3af9 (opens in a new tab)
- git.kernel.org/stable/c/7cec2c3bfe84539c415f5e16f989228eba1d2f1e (opens in a new tab)
- git.kernel.org/stable/c/f6be298cc1042f24d521197af29c7c4eb95af4d5 (opens in a new tab)
- git.kernel.org/stable/c/3eac973eb5cb2b874b3918f924798afc5affd46b (opens in a new tab)
- git.kernel.org/stable/c/eb1d4ce2609584eeb7694866f34d4b213caa3af9 (opens in a new tab)
- git.kernel.org/stable/c/549aac9655320c9b245a24271b204668c5d40430 (opens in a new tab)
- git.kernel.org/stable/c/e1f010844443c389bc552884ac5cfa47de34d54c (opens in a new tab)
- git.kernel.org/stable/c/a3ab508a4853a9f5ae25a7816a4889f09938f63c (opens in a new tab)
- git.kernel.org/stable/c/cde43031df533751b4ead37d173922feee2f550f (opens in a new tab)
- ubuntu.com/security/notices/USN-7088-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7088-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7088-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-7088-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-7100-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7100-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7088-5 (opens in a new tab)
- ubuntu.com/security/notices/USN-7119-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7123-1 (opens in a new tab)