Skip to main content
CVE-2024-4442VulnerabilityPublished Updated

CVE-2024-4442: Salon Booking System (WordPress plugin) · Path Traversal

Affects Salon Booking System (WordPress plugin)Source CVE Database V5

0

Mentioned vulnerabilities

Not known to be exploited · CVSS 9.1 Critical · fixed in 10.0 : patch Salon Booking System (WordPress plugin) as a priority.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.2% chance of exploitation in 30 days – higher than 68% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 10.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 May 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Affected software

ProductAffectedFixed in
wordpresschef Salon Booking System – Free VersionAffected
  • =0
Fixed in–

AI-suggested

A complete fix is available in version 10.0 of the Salon Booking System – Free Version plugin. Users should upgrade to version 10.0 or later to fully remediate this vulnerability. Versions 9.9 and later include partial fixes but do not fully resolve the issue. No additional mitigations are specified.

Description

The Salon booking system plugin for WordPress is vulnerable to arbitrary file deletion in all versions up to, and including, 9.8. This is due to the plugin not properly validating the path of an uploaded file prior to deleting it. This makes it possible for unauthenticated attackers to delete arbitrary files, including the wp-config.php file, which can make site takeover and remote code execution possible. This was partially patched in 9.9, and sufficiently patched in 10.0. CVE-2024-37231 appears to be a duplicate of this issue.

References

Community reviews

Loading reviews…