CVE-2024-44610: PCAN-Ethernet Gateway FD · Command Injection
Source CVE Database V5
Not known to be exploited · CVSS 5.6 Medium · fixed in 2.11.0 : update affected systems when convenient.
Data as of 26 Oct 2026, 12:54 UTC
- EPSS
- 0.9% chance of exploitation in 30 days – higher than 61% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.11.0, 1.3.0
CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 1 Oct 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
AI-suggested
Organizations should implement strict access controls to limit who can access the Software Update interface on PCAN-Ethernet Gateway devices, ensuring only trusted administrators have high privilege accounts. Network segmentation should isolate these devices from untrusted networks to reduce the risk of local privilege escalation leading to exploitation. Monitoring and logging of update processes and command executions on the gateway devices can help detect suspicious activity early. If you cannot patch yet, consider disabling remote update functionality if feasible or applying compensating controls such as application-layer firewalls to restrict access. Conduct internal audits to verify that no unauthorized commands or changes have been made to the devices. Additionally, enforce strong authentication mechanisms and keep device firmware and management software up to date to reduce the attack surface.
Description
PCAN-Ethernet Gateway FD before 1.3.0 and PCAN-Ethernet Gateway before 2.11.0 are vulnerable to Command injection via shell metacharacters in a Software Update to processing.php.