CVE-2024-44974: Linux kernel · mptcp: pm: avoid possible UaF when selecting endp
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 7.8 High · fixed in 5.15.0-1072.78~20.04.1 : patch Linux kernel soon.
Data as of 27 Oct 2026, 00:00 UTC
- Patch
- Available – fixed in 5.15.0-1072.78~20.04.1, 5.15.0-1078.87~20.04.1, 5.15.0-1071.79~20.04.1 +52
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 4 Sep 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
- ubuntu.com/security/notices/USN-7100-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7100-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7123-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7144-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7154-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7155-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7156-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7154-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7194-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7196-1 (opens in a new tab)
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-gkeoppkg:deb/ubuntu/linux-gkeop?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and has been released in multiple fixed Linux kernel versions starting from 5.15.0-1055.62~20.04.1 and later. Users and administrators should upgrade to these fixed kernel versions to remediate the vulnerability. No additional mitigation is required beyond applying the official kernel updates.
Description
CVE-2024-44974 is a high-severity use-after-free vulnerability in the Linux kernel's multipath TCP (mptcp) path manager. The flaw occurs when endpoint entries are selected and referenced outside the RCU-protected section, potentially leading to use-after-free conditions. This vulnerability has been addressed by copying the required information within the RCU section to prevent unsafe dereferencing. Multiple Linux kernel versions prior to fixed releases are affected.
References
- ubuntu.com/security/CVE-2024-44974 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2024-44974 (opens in a new tab)
- git.kernel.org/linus/48e50dcbcbaaf713d82bf2da5c16aeced94ad07d (opens in a new tab)
- git.kernel.org/stable/c/9a9afbbc3fbfca4975eea4aa5b18556db5a0c0b8 (opens in a new tab)
- git.kernel.org/stable/c/0201d65d9806d287a00e0ba96f0321835631f63f (opens in a new tab)
- git.kernel.org/stable/c/48e50dcbcbaaf713d82bf2da5c16aeced94ad07d (opens in a new tab)
- ubuntu.com/security/notices/USN-7100-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7100-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7123-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7144-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7154-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7155-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7156-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7154-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7194-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7196-1 (opens in a new tab)