Skip to main content
VulnerabilityPublished Updated

CVE-2024-44988: Linux kernel · net: dsa: mv88e6xxx: Fix out-of-bound access

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 8.8 High · fixed in 5.4.0-1135.145~18.04.1 : patch Linux kernel soon.

Data as of 26 Oct 2026, 23:59 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.4.0-1135.145~18.04.1, 5.4.0-1140.147~18.04.1, 5.4.0-1139.148~18.04.1 +75
CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Sep 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-50.51
Fixed in
  • 6.8.0-50.51
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1020.22
Fixed in
  • 6.8.0-1020.22
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1020.23
Fixed in
  • 6.8.0-1020.23
Ubuntu 24.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1019.21
Fixed in
  • 6.8.0-1019.21
Ubuntu 24.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1015.19
Fixed in
  • 6.8.0-1015.19
Ubuntu 24.04 LTSlinux-gkeoppkg:deb/ubuntu/linux-gkeop?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1002.4
Fixed in
  • 6.8.0-1002.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied promptly. Ubuntu has released fixed kernel versions including 5.4.0-1135.145~18.04.1 and others listed in the advisory. Users should update to these fixed versions to remediate the vulnerability. No additional mitigation steps are indicated by the vendor advisory.

Description

CVE-2024-44988 is a high-severity vulnerability in the Linux kernel's mv88e6xxx DSA driver that causes an out-of-bound array access. This occurs when an ATU violation triggered by a CPU Load operation results in an SPID value larger than the maximum number of ports, potentially leading to memory corruption. The flaw affects multiple Linux kernel versions prior to fixed releases in the 5.4.x series and others. A patch is available and has been released by Ubuntu as part of their security updates.

References

Community reviews

Loading reviews…