CVE-2024-45301: mintty · Improper Input Validation
Affects minttySource GCVE Database
Not known to be exploited · CVSS 5.3 Medium : upgrade to 3.7.5 when convenient.
Data as of 8 Nov 2026, 20:49 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 5.3 |
|---|
- Patch
- Available – fixed in 3.7.5
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 12 Nov 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 8 Nov 2026.
What to do
Upgrade mintty to 3.7.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| mintty mintty | Affected
| Fixed in
|
AI-suggested
Upgrade mintty to version 3.7.5 or later, where this vulnerability is fixed. No other mitigation is specified or required once the update is applied.
Description
CVE-2024-45301 is an improper input validation vulnerability in mintty terminal emulator versions 2.3.6 through 3.7.4. Certain escape sequences can cause mintty to access files at attacker-specified network paths, potentially leaking NTLM hashes to a remote host. This allows attackers to capture authentication hashes that can be used in Pass-the-Hash attacks. The issue is fixed in version 3.7.5.