Skip to main content
VulnerabilityPublished Updated

CVE-2024-45409: ruby-saml · Improper Verification of Cryptographic Signature

Affects ruby-samlSource CVE Database V5

0
Compare

Public exploit available · 10% EPSS · CVSS 10.0 Critical : upgrade to 1.17.0 or 1.12.3 as a priority.

Data as of 4 Nov 2026, 00:28 UTC

CVSS 3.1 base score
10.0Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.110.0
EPSS
10.6% chance of exploitation in 30 days – higher than 95% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CISA SSVC
Exploitation
Proof of concept is public or traded
Automatable
Attackers can reliably automate steps 1–4 of the kill chain
Technical impact
Total control over the software or total information disclosure

CISA SSVC assessment, 2024-10-16.

Patch
Available – fixed in 1.17.0, 1.12.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 10 Sep 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CISA SSVC: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

Timeline

  1. CVE ID reserved

    by GitHub, Inc.

    , 13 days before disclosure

  2. CVE published

    on cve.org

    , t = 0

  3. CISA SSVC assessment

    proof of concept public

    , 36 days after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA SSVC, the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade ruby-saml to 1.17.0 or 1.12.3.

Affected software

ProductAffectedFixed in
SAML-Toolkitsruby-samlAffected
  • >=1.13.0 <1.17.0
Fixed in
  • 1.17.0
SAML-Toolkitsruby-samlAffected
  • <1.12.3
Fixed in
  • 1.12.3

AI-suggested

Upgrade ruby-saml to version 1.12.3 or later if using a version <= 1.12.2, or to version 1.17.0 or later if using versions between 1.13.0 and 1.16.0. These versions contain the official fixes for the signature verification flaw. No other mitigations are indicated by the vendor advisory.

Description

The Ruby SAML library is for implementing the client side of a SAML authorization. Ruby-SAML in <= 12.2 and 1.13.0 <= 1.16.0 does not properly verify the signature of the SAML Response. An unauthenticated attacker with access to any signed saml document (by the IdP) can thus forge a SAML Response/Assertion with arbitrary contents. This would allow the attacker to log in as arbitrary user within the vulnerable system. This vulnerability is fixed in 1.17.0 and 1.12.3.

References

Community reviews

Loading reviews…