Skip to main content
VulnerabilityPublished Updated

CVE-2024-45491: libexpat · Integer Overflow or Wraparound

Affects libexpatSource CVE Database V5

0

Not known to be exploited · CVSS 7.3 High : upgrade to 2.6.3 soon.

Data as of 26 Oct 2026, 13:47 UTC

CVSS 3.1 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.1% chance of exploitation in 30 days – higher than 66% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.6.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Aug 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade libexpat/libexpat to 2.6.3.

Affected software

ProductAffectedFixed in
GitHublibexpat/libexpatpkg:github/libexpat/libexpatOther threatsAffected
  • <2.6.3
Fixed in
  • 2.6.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in libexpat version 2.6.3. Users and maintainers of libexpat should upgrade to version 2.6.3 or later to remediate this vulnerability.

Description

An issue was discovered in libexpat before 2.6.3. dtdCopy in xmlparse.c can have an integer overflow for nDefaultAtts on 32-bit platforms (where UINT_MAX equals SIZE_MAX).

References

Community reviews

Loading reviews…