CVE-2024-46507: yeti-platform · SSTI
Affects yeti-platformSource CVE Database V5
Not known to be exploited · public detection template (Nuclei) · CVSS 7.3 High : upgrade to 2.1.12 soon.
Data as of 26 Oct 2026, 13:47 UTC
- EPSS
- 3.9% chance of exploitation in 30 days – higher than 90% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.1.12
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 8 May 2026
Detectable: evidence found.
nuclei template: Yeti Platform < 2.1.12 - Server-Side Template Injection to RCE
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade yeti-platform to 2.1.12.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubyeti-platformpkg:github/yeti-platformOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, restricting access to the vulnerable functionality and applying application-level input validation may reduce exposure.
Description
CVE-2024-46507 is a server-side template injection (SSTI) vulnerability in the custom template export function of yeti-platform versions before 2.1.12. This vulnerability allows unauthenticated attackers to execute code on the application server. It has a high severity with a CVSS score of 7.3, indicating significant risk if exploited. There are no known exploits in the wild at this time.