CVE-2024-46508: yeti-platform · Use of Hard-coded Credentials
Affects yeti-platformSource CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 2.1.12 soon.
Data as of 26 Oct 2026, 13:47 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.1.12
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 8 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade yeti-platform to 2.1.12.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubyeti-platformpkg:github/yeti-platformOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
In the meantime, users should immediately change the default JWT secret by setting YETI_AUTH_SECRET_KEY to a strong, unique value other than the default SECRET to prevent unauthorized token generation.
Description
A vulnerability in yeti-platform versions before 2.1.12 allows attackers to generate valid JWT tokens if the default secret (SECRET) is not changed by setting YETI_AUTH_SECRET_KEY. This can lead to unauthorized access due to predictable authentication tokens. The vulnerability has a high severity with a CVSS score of 7.5. Users should verify and change the authentication secret key to mitigate the risk.