CVE-2024-46818: Linux kernel · drm/amd/display: Check gpio_id before used as array index
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 7.8 High · fixed in 5.4.0-1135.145~18.04.1 : patch Linux kernel soon.
Data as of 26 Oct 2026, 23:57 UTC
- Patch
- Available – fixed in 5.4.0-1135.145~18.04.1, 5.4.0-1140.147~18.04.1, 5.4.0-1139.148~18.04.1 +75
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 27 Sep 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
- ubuntu.com/security/notices/USN-7088-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7088-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7088-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-7088-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-7100-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7100-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7088-5 (opens in a new tab)
- ubuntu.com/security/notices/USN-7119-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7123-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7144-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7154-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7155-1 (opens in a new tab)
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-gkeoppkg:deb/ubuntu/linux-gkeop?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch addressing this vulnerability is available and has been released in multiple Linux kernel versions including 5.4.0-1135.145~18.04.1 and later. Users and administrators should update affected Linux kernel packages to these fixed versions as provided by their distribution vendors. No additional mitigations are specifically required beyond applying the official fixes.
Description
CVE-2024-46818 is a high-severity vulnerability in the Linux kernel's AMD DRM display driver where the gpio_id value was not properly checked before being used as an array index. This flaw could lead to out-of-bounds array access due to the use of an invalid GPIO_ID_UNKNOWN (-1) value, causing multiple buffer overruns. The issue affects various Linux kernel versions prior to fixed releases in the 5.4.x and 5.15.x series. A patch is available and has been incorporated into several updated kernel versions.
References
- ubuntu.com/security/CVE-2024-46818 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2024-46818 (opens in a new tab)
- git.kernel.org/linus/2a5626eeb3b5eec7a36886f9556113dd93ec8ed6 (opens in a new tab)
- git.kernel.org/stable/c/8520fdc8ecc38f240a8e9e7af89cca6739c3e790 (opens in a new tab)
- git.kernel.org/stable/c/40c2e8bc117cab8bca8814735f28a8b121654a84 (opens in a new tab)
- git.kernel.org/stable/c/0184cca30cad74d88f5c875d4e26999e26325700 (opens in a new tab)
- git.kernel.org/stable/c/276e3fd93e3beb5894eb1cc8480f9f417d51524d (opens in a new tab)
- git.kernel.org/stable/c/08e7755f754e3d2cef7d3a7da538d33526bd6f7c (opens in a new tab)
- git.kernel.org/stable/c/3d4198ab612ad48f73383ad3bb5663e6f0cdf406 (opens in a new tab)
- git.kernel.org/stable/c/2a5626eeb3b5eec7a36886f9556113dd93ec8ed6 (opens in a new tab)
- ubuntu.com/security/notices/USN-7088-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7088-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7088-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-7088-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-7100-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7100-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7088-5 (opens in a new tab)
- ubuntu.com/security/notices/USN-7119-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7123-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7144-1 (opens in a new tab)