CVE-2024-47596: gstreamer · Out-of-bounds Read
Affects gstreamerSource GCVE Database
Not known to be exploited · CVSS 5.1 Medium : upgrade to 1.24.10 when convenient.
Data as of 30 Oct 2026, 00:26 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 4.0 | 5.1 |
|---|
- Patch
- Available – fixed in 1.24.10
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 11 Dec 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade gstreamer to 1.24.10.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| gstreamer gstreamer | Affected
| Fixed in
|
AI-suggested
Upgrade GStreamer to version 1.24.10 or later, where this vulnerability is fixed. No other mitigations are specified or required.
Description
CVE-2024-47596 is an out-of-bounds read vulnerability in the GStreamer media-handling library. It occurs in the qtdemux_parse_svq3_stsd_data function when processing certain input data, leading to reading beyond the buffer boundary. This can cause the process to read up to 4GB of memory or crash due to segmentation faults. The issue is fixed in version 1.24.10.
References
- securitylab.github.com/advisories/GHSL-2024-244_Gstreamer/ (opens in a new tab)
- gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/8059.patch (opens in a new tab)
- gstreamer.freedesktop.org/security/sa-2024-0015.html (opens in a new tab)
- lists.debian.org/debian-lts-announce/2025/02/msg00035.html (opens in a new tab)