Skip to main content
VulnerabilityPublished Updated

CVE-2024-47776: gstreamer · Out-of-bounds Read

Affects gstreamerSource GCVE Database

0
Compare

Not known to be exploited · CVSS 5.1 Medium : upgrade to 1.24.10 when convenient.

Data as of 30 Oct 2026, 00:27 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 4.05.1
Patch
Available – fixed in 1.24.10
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Dec 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade gstreamer to 1.24.10.

Affected software

ProductAffectedFixed in
gstreamer gstreamerAffected
  • <1.24.10
Fixed in
  • 1.24.10

AI-suggested

Users should upgrade to GStreamer version 1.24.10 or later where this vulnerability is fixed. No other mitigations are indicated or required.

Description

CVE-2024-47776 is an out-of-bounds read vulnerability in the gst_wavparse_cue_chunk function of the GStreamer media-handling library. The flaw arises from a miscalculation of the chunk size, causing a buffer size check to fail and allowing reads beyond the data buffer. This can lead to application crashes or potential leakage of sensitive data. The issue is fixed in GStreamer version 1.24.10.

References

Community reviews

Loading reviews…