Skip to main content
VulnerabilityPublished Updated

CVE-2024-47775: gstreamer · Out-of-bounds Read

Affects gstreamerSource GCVE Database

0
Compare

Not known to be exploited · CVSS 5.1 Medium : upgrade to 1.24.10 when convenient.

Data as of 30 Oct 2026, 00:27 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 4.05.1
Patch
Available – fixed in 1.24.10
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Dec 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade gstreamer to 1.24.10.

Affected software

ProductAffectedFixed in
gstreamer gstreamerAffected
  • <1.24.10
Fixed in
  • 1.24.10

AI-suggested

This vulnerability is fixed in GStreamer version 1.24.10. Users and administrators should upgrade to version 1.24.10 or later to remediate this issue. No additional mitigation steps are indicated by the vendor advisory.

Description

CVE-2024-47775 is an out-of-bounds read vulnerability in the GStreamer media-handling library, specifically in the parse_ds64 function of gstwavparse.c. The function fails to verify buffer size before reading, which can cause reading beyond buffer limits. This may result in application crashes or potential leakage of sensitive data. The issue is fixed in version 1.24.10.

References

Community reviews

Loading reviews…