Skip to main content
VulnerabilityPublished Updated

CVE-2024-47667: Linux kernel · AM65x SR 1.0

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 7.3 High · fixed in 5.4.0-1135.145~18.04.1 : patch Linux kernel soon.

Data as of 26 Oct 2026, 23:44 UTC

CVSS 3.1 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.4.0-1135.145~18.04.1, 5.4.0-1140.147~18.04.1, 5.4.0-1139.148~18.04.1 +75
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Oct 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-50.51
Fixed in
  • 6.8.0-50.51
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1020.22
Fixed in
  • 6.8.0-1020.22
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1020.23
Fixed in
  • 6.8.0-1020.23
Ubuntu 24.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1019.21
Fixed in
  • 6.8.0-1019.21
Ubuntu 24.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1015.19
Fixed in
  • 6.8.0-1015.19
Ubuntu 24.04 LTSlinux-gkeoppkg:deb/ubuntu/linux-gkeop?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1002.4
Fixed in
  • 6.8.0-1002.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and included in Linux kernel versions 5.4.0-1135.145~18.04.1 and later. Users should upgrade to these fixed kernel versions or later to mitigate the vulnerability. The workaround limits PCIe maximum read request and payload sizes to 128 bytes, preventing the erratum from triggering. No additional mitigation is required as the fix addresses the issue directly.

Description

CVE-2024-47667 addresses a hardware erratum in AM65x/DRA80xM Processors Silicon Revision 1.0 that can cause PCIe packet payload corruption when inbound TLPs span more than two internal AXI 128-byte bursts. This corruption may lead to system hangs or application failures. The Linux kernel patch implements a workaround by limiting the maximum read request size and payload size to 128 bytes. The issue affects specific Linux kernel versions prior to 5.4.0-1135.145~18.04.1 and related builds. Fixed versions are available, and the erratum is resolved in later silicon revisions.

References

Community reviews

Loading reviews…