CVE-2024-47774: gstreamer · Out-of-bounds Read
Affects gstreamerSource GCVE Database
Not known to be exploited · CVSS 5.1 Medium : upgrade to 1.24.10 when convenient.
Data as of 30 Oct 2026, 00:27 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 4.0 | 5.1 |
|---|
- Patch
- Available – fixed in 1.24.10
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 11 Dec 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade gstreamer to 1.24.10.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| gstreamer gstreamer | Affected
| Fixed in
|
AI-suggested
Upgrade GStreamer to version 1.24.10 or later, where this vulnerability is fixed. No other mitigation is indicated by the vendor advisory.
Description
CVE-2024-47774 is an out-of-bounds read vulnerability in GStreamer's gst_avi_subtitle_parse_gab2_chunk function. The flaw arises from improper validation of the name_length value read from input, leading to an integer overflow and subsequent memory access beyond the buffer. This issue is fixed in version 1.24.10.
References
- securitylab.github.com/advisories/GHSL-2024-262_Gstreamer/ (opens in a new tab)
- github.com/github/securitylab-vulnerabilities/issues/1826 (opens in a new tab)
- gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/8043.patch (opens in a new tab)
- lists.debian.org/debian-lts-announce/2025/02/msg00035.html (opens in a new tab)