CVE-2024-49690: Qi Blocks (WordPress plugin) · Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File
Affects Qi Blocks (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 1.3.3 soon.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.3.3
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 23 Oct 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade qode/qi-blocks to 1.3.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Packagistqode/qi-blockspkg:composer/qode/qi-blocksOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, consider disabling or restricting access to the vulnerable Qi Blocks plugin and applying web application firewall rules to block suspicious requests targeting file inclusion.
Description
Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in Qode Qi Blocks qi-blocks.This issue affects Qi Blocks: from n/a through <= 1.3.2.