Skip to main content
VulnerabilityPublished Updated

CVE-2024-49895: Linux kernel · drm/amd/display: Fix index out of bounds in DCN30 degamma hardware format translation

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 7.8 High · fixed in 5.15.0-1073.79~20.04.1 : patch Linux kernel soon.

Data as of 26 Oct 2026, 23:42 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.15.0-1073.79~20.04.1, 5.15.0-1078.87~20.04.1, 5.15.0-1072.80~20.04.1 +58
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Oct 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-54.56
Fixed in
  • 6.8.0-54.56
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1023.25
Fixed in
  • 6.8.0-1023.25
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1025.30
Fixed in
  • 6.8.0-1025.30
Ubuntu 24.04 LTSlinux-azure-6.11pkg:deb/ubuntu/linux-azure-6.11?arch=source&distro=nobleOther threatsAffected
  • <6.11.0-1012.12~24.04.1
Fixed in
  • 6.11.0-1012.12~24.04.1
Ubuntu 24.04 LTSlinux-azure-nvidiapkg:deb/ubuntu/linux-azure-nvidia?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1014.15
Fixed in
  • 6.8.0-1014.15
Ubuntu 24.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1024.26
Fixed in
  • 6.8.0-1024.26

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied by upgrading to the fixed Linux kernel versions 5.15.0-1066.69 and later as listed in the established facts. The vendor advisory from Ubuntu confirms the fix is included in updated kernel releases. Users should update their systems promptly to these patched versions to mitigate the vulnerability. No additional mitigations or workarounds are indicated by the vendor advisory.

Description

A high-severity vulnerability (CVE-2024-49895) in the Linux kernel's AMD GPU driver was fixed. The flaw involved an index out of bounds error in the DCN30 degamma hardware format translation function, which could lead to buffer overflow conditions. This issue was addressed by adding bounds checking to prevent out-of-range accesses. Multiple Linux kernel versions, including various 4.x and 5.15.x releases, are affected. The vulnerability has been patched in updated kernel versions.

References

Community reviews

Loading reviews…