Skip to main content
VulnerabilityPublished Updated

CVE-2024-50349: git · Improper Encoding or Escaping of Output

Affects gitSource GCVE Database

0
Compare

Not known to be exploited · CVSS 2.1 Low : upgrade to 2.47.2 when convenient.

Data as of 30 Oct 2026, 00:28 UTC

CVSS 4.0 base score
2.1Low
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 4.02.1
Patch
Available – fixed in 2.47.2
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Jan 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade git to 2.47.2.

Affected software

ProductAffectedFixed in
git gitAffected
  • <=2.40.3
  • >=2.41.0 <=2.41.2
  • >=2.42.0 <=2.42.3
  • >=2.43.0 <=2.43.5
  • >=2.44.0 <=2.44.2
  • >=2.45.0 <=2.45.2
  • >=2.46.0 <=2.46.2
  • >=2.47.0 <2.47.2
  • =2.48.0
Fixed in
  • 2.47.2

AI-suggested

A fix is available in Git version 2.47.2 and later. Users should upgrade to these versions to remediate the vulnerability. For users unable to upgrade immediately, it is recommended to avoid cloning from untrusted URLs, especially recursive clones, to reduce the risk of exploitation.

Description

CVE-2024-50349 is a vulnerability in Git where the terminal prompt for credentials prints hostnames without properly encoding or escaping ANSI escape sequences. This can allow attackers to craft malicious URLs that manipulate the terminal display, potentially misleading users into providing credentials to attacker-controlled sites. The issue affects multiple Git versions and has been fixed in version 2.47.2 and later. Users are advised to upgrade to patched versions or avoid cloning from untrusted URLs.

References

Community reviews

Loading reviews…