Skip to main content
VulnerabilityPublished Updated

CVE-2025-31651: Org.apache.tomcat:tomcat catalina: Apache Tomcat Rewrite rule bypass

Affects org.apache.tomcat:tomcat-catalinaSource GCVE Database

0
Compare

Not known to be exploited · CVSS 6.9 Medium : upgrade to 9.0.104 when convenient.

Data as of 30 Oct 2026, 02:30 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 9.0.104, 10.1.40, 11.0.6
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:U

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Apr 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade org.apache.tomcat:tomcat-catalina and org.apache.tomcat.embed:tomcat-embed-core to 9.0.104; org.apache.tomcat:tomcat-catalina and org.apache.tomcat.embed:tomcat-embed-core to 10.1.40; org.apache.tomcat:tomcat-catalina and org.apache.tomcat.embed:tomcat-embed-core to 11.0.6.

Affected software

ProductAffectedFixed in
Mavenorg.apache.tomcat:tomcat-catalinaAffected
  • >=9.0.76 <9.0.104
Fixed in
  • 9.0.104
Mavenorg.apache.tomcat:tomcat-catalinaAffected
  • >=10.1.10 <10.1.40
Fixed in
  • 10.1.40
Mavenorg.apache.tomcat:tomcat-catalinaAffected
  • >=11.0.0-M2 <11.0.6
Fixed in
  • 11.0.6
Mavenorg.apache.tomcat.embed:tomcat-embed-coreAffected
  • >=9.0.76 <9.0.104
Fixed in
  • 9.0.104
Mavenorg.apache.tomcat.embed:tomcat-embed-coreAffected
  • >=10.1.10 <10.1.40
Fixed in
  • 10.1.40
Mavenorg.apache.tomcat.embed:tomcat-embed-coreAffected
  • >=11.0.0-M2 <11.0.6
Fixed in
  • 11.0.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade affected Apache Tomcat instances to versions 9.0.104, 10.1.40, or 11.0.6 where this vulnerability is fixed. Since a patch is available, applying the official update is the recommended remediation. No alternative mitigations or workarounds are indicated in the advisory.

Description

Apache Tomcat contains a vulnerability in its rewrite rule processing that allows specially crafted requests to bypass certain rewrite rules under a subset of unlikely configurations. This bypass can circumvent security constraints enforced by those rules. The issue affects multiple versions across Tomcat 8.5.x, 9.0.x, 10.1.x, and 11.0.x branches. Fixed versions are 9.0.104, 10.1.40, and 11.0.6.

References

Community reviews

Loading reviews…