CVE-2025-49125: Org.apache.tomcat:tomcat catalina: Apache Tomcat - Security constraint bypass for pre/post-resources
Affects org.apache.tomcat:tomcat-catalinaSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 11.0.8 soon.
Data as of 30 Oct 2026, 02:31 UTC
Thin evidence
One scorer or none| CISA-ADP | CVSS 3.1 | 7.5 |
|---|
- Patch
- Available – fixed in 11.0.8, 10.1.42, 9.0.106
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 16 Jun 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade org.apache.tomcat:tomcat-catalina and org.apache.tomcat.embed:tomcat-embed-core to 11.0.8; org.apache.tomcat:tomcat-catalina and org.apache.tomcat.embed:tomcat-embed-core to 10.1.42; org.apache.tomcat:tomcat-catalina and org.apache.tomcat.embed:tomcat-embed-core to 9.0.106.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Mavenorg.apache.tomcat:tomcat-catalina | Affected
| Fixed in
|
| Mavenorg.apache.tomcat:tomcat-catalina | Affected
| Fixed in
|
| Mavenorg.apache.tomcat:tomcat-catalina | Affected
| Fixed in
|
| Mavenorg.apache.tomcat.embed:tomcat-embed-core | Affected
| Fixed in
|
| Mavenorg.apache.tomcat.embed:tomcat-embed-core | Affected
| Fixed in
|
| Mavenorg.apache.tomcat.embed:tomcat-embed-core | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade affected Apache Tomcat installations to versions 11.0.8, 10.1.42, or 9.0.106 or later, where the vulnerability is fixed. Since a patch is available, applying these official updates is the recommended remediation. No alternative mitigations or workarounds are indicated in the advisory.
Description
CVE-2025-49125 is a security constraint bypass vulnerability in Apache Tomcat affecting versions 8.5.0 through 8.5.100, 9.0.0.M1 through 9.0.105, 10.1.0-M1 through 10.1.41, and 11.0.0-M1 through 11.0.7. The flaw allows access to PreResources or PostResources mounted at non-root locations via unexpected paths that may not be protected by the intended security constraints, enabling authentication bypass. Fixed versions are 8.5.101+, 9.0.106+, 10.1.42+, and 11.0.8+. The vulnerability has a CVSS 4.0 base score of 6.3 (medium severity).
References
- nvd.nist.gov/vuln/detail/CVE-2025-49125 (opens in a new tab)
- github.com/apache/tomcat/commit/7617b9c247bc77ed0444dd69adcd8aa48777886c (opens in a new tab)
- github.com/apache/tomcat/commit/9418e3ff9f1f4c006b4661311ae9376c52d162b9 (opens in a new tab)
- github.com/apache/tomcat/commit/d94bd36fb7eb32e790dae0339bc249069649a637 (opens in a new tab)
- github.com/apache/tomcat (opens in a new tab)
- lists.apache.org/thread/m66cytbfrty9k7dc4cg6tl1czhsnbywk (opens in a new tab)
- lists.debian.org/debian-lts-announce/2025/07/msg00009.html (opens in a new tab)
- tomcat.apache.org/security-10.html (opens in a new tab)
- tomcat.apache.org/security-11.html (opens in a new tab)
- tomcat.apache.org/security-9.html (opens in a new tab)
- openwall.com/lists/oss-security/2025/06/16/2 (opens in a new tab)