Skip to main content
VulnerabilityPublished Updated

CVE-2025-46701: Org.apache.tomcat:tomcat catalina: Apache Tomcat - CGI security constraint bypass

Affects org.apache.tomcat:tomcat-catalinaSource GCVE Database

0
Compare
Authoritative record:CVE-2025-46701· High 7.3

Not known to be exploited · CVSS 7.3 High : upgrade to 9.0.105 soon.

Data as of 30 Oct 2026, 02:30 UTC

CVSS 3.1 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.17.3
Patch
Available – fixed in 9.0.105, 10.1.41, 11.0.7
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 May 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade org.apache.tomcat:tomcat-catalina and org.apache.tomcat.embed:tomcat-embed-core to 9.0.105; org.apache.tomcat:tomcat-catalina and org.apache.tomcat.embed:tomcat-embed-core to 10.1.41; org.apache.tomcat:tomcat-catalina and org.apache.tomcat.embed:tomcat-embed-core to 11.0.7.

Affected software

ProductAffectedFixed in
Mavenorg.apache.tomcat:tomcat-catalinaAffected
  • >=9.0.0.M1 <9.0.105
Fixed in
  • 9.0.105
Mavenorg.apache.tomcat:tomcat-catalinaAffected
  • >=10.1.0-M1 <10.1.41
Fixed in
  • 10.1.41
Mavenorg.apache.tomcat:tomcat-catalinaAffected
  • >=11.0.0-M1 <11.0.7
Fixed in
  • 11.0.7
Mavenorg.apache.tomcat.embed:tomcat-embed-coreAffected
  • >=9.0.0.M1 <9.0.105
Fixed in
  • 9.0.105
Mavenorg.apache.tomcat.embed:tomcat-embed-coreAffected
  • >=10.1.0-M1 <10.1.41
Fixed in
  • 10.1.41
Mavenorg.apache.tomcat.embed:tomcat-embed-coreAffected
  • >=11.0.0-M1 <11.0.7
Fixed in
  • 11.0.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and users are strongly recommended to upgrade to Apache Tomcat versions 8.5.101 or later, 9.0.105 or later, 10.1.41 or later, or 11.0.7 or later to remediate this vulnerability. No other mitigation steps are indicated by the vendor advisory.

Description

Apache Tomcat versions 8.5.0 through 8.5.100, 9.0.0.M1 through 9.0.104, 10.1.0-M1 through 10.1.40, and 11.0.0-M1 through 11.0.6 contain a vulnerability in the CGI servlet where improper handling of case sensitivity allows bypassing security constraints applied to the pathInfo component of a URI. This security constraint bypass is fixed in versions 8.5.101 and later, 9.0.105 and later, 10.1.41 and later, and 11.0.7 and later. The vulnerability has a medium severity with a CVSS score of 6.3.

References

Community reviews

Loading reviews…