CVE-2025-46701: Apache Tomcat · Improper Handling of Case Sensitivity
Affects Apache TomcatSource CVE Database V5
Not known to be exploited · CVSS 7.3 High · fixed in 11.0.7 : patch Apache Tomcat soon.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 3.1% chance of exploitation in 30 days – higher than 87% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 11.0.7
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 29 May 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Mavenorg.apache.tomcat/tomcat-catalinapkg:maven/org.apache.tomcat/tomcat-catalinaOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
- Immediately upgrade Apache Tomcat to the fixed versions: 11.0.7, 10.1.41, or 9.0.105 depending on your deployment.
- Audit all web applications using the CGI servlet to identify usage of pathInfo components and verify that security constraints are correctly enforced post-upgrade.
- Implement strict access controls and input validation on URIs, particularly focusing on case sensitivity handling in web server and application configurations.
- Employ Web Application Firewalls (WAFs) with rules designed to detect and block suspicious URI manipulations that exploit case sensitivity issues.
- Monitor logs for unusual access patterns or attempts to bypass security constraints via case variations in URLs.
- For legacy systems that cannot be immediately upgraded, consider disabling the CGI servlet if not required or restricting its usage to trusted networks.
- Conduct penetration testing focused on URI manipulation to ensure that security constraints cannot be bypassed.
- Maintain an incident response plan to quickly address any exploitation attempts.
- Stay informed about any emerging exploits or patches related to this vulnerability.
Description
Improper Handling of Case Sensitivity vulnerability in Apache Tomcat's GCI servlet allows security constraint bypass of security constraints that apply to the pathInfo component of a URI mapped to the CGI servlet. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.6, from 10.1.0-M1 through 10.1.40, from 9.0.0.M1 through 9.0.104. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.7, 10.1.41 or 9.0.105, which fixes the issue.