Skip to main content
VulnerabilityPublished Updated

CVE-2025-48988: Org.apache.tomcat:tomcat catalina: Apache Tomcat - DoS

Affects org.apache.tomcat:tomcat-catalinaSource GCVE Database

0
Compare
Authoritative record:CVE-2025-48988· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 11.0.8 soon.

Data as of 30 Oct 2026, 01:44 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.17.5
Patch
Available – fixed in 11.0.8, 10.1.42, 9.0.106
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade org.apache.tomcat:tomcat-catalina and org.apache.tomcat.embed:tomcat-embed-core to 11.0.8; org.apache.tomcat:tomcat-catalina and org.apache.tomcat.embed:tomcat-embed-core to 10.1.42; org.apache.tomcat:tomcat-catalina and org.apache.tomcat.embed:tomcat-embed-core to 9.0.106.

Affected software

ProductAffectedFixed in
Mavenorg.apache.tomcat:tomcat-catalinaAffected
  • >=11.0.0-M1 <11.0.8
Fixed in
  • 11.0.8
Mavenorg.apache.tomcat:tomcat-catalinaAffected
  • >=10.1.0-M1 <10.1.42
Fixed in
  • 10.1.42
Mavenorg.apache.tomcat:tomcat-catalinaAffected
  • >=9.0.0.M1 <9.0.106
Fixed in
  • 9.0.106
Mavenorg.apache.tomcat.embed:tomcat-embed-coreAffected
  • >=11.0.0-M1 <11.0.8
Fixed in
  • 11.0.8
Mavenorg.apache.tomcat.embed:tomcat-embed-coreAffected
  • >=10.1.0-M1 <10.1.42
Fixed in
  • 10.1.42
Mavenorg.apache.tomcat.embed:tomcat-embed-coreAffected
  • >=9.0.0.M1 <9.0.106
Fixed in
  • 9.0.106

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade affected Apache Tomcat versions to 11.0.8, 10.1.42, or 9.0.106 or later, which contain official fixes for this vulnerability. No other mitigation or temporary workaround is indicated by the vendor advisory. Applying the official patch is the recommended remediation.

Description

Apache Tomcat versions from 8.5.0 through 8.5.100, 9.0.0.M1 through 9.0.105, 10.1.0-M1 through 10.1.41, and 11.0.0-M1 through 11.0.7 are affected by a denial of service (DoS) vulnerability related to resource allocation without limits or throttling during multipart uploads. This vulnerability can cause the server to exhaust resources, leading to service disruption. Fixed versions are 8.5.101 or later, 9.0.106 or later, 10.1.42 or later, and 11.0.8 or later.

References

Community reviews

Loading reviews…