Skip to main content
CVE-2024-50427VulnerabilityPublished Updated

CVE-2024-50427: SurveyJS (WordPress plugin) · Unrestricted File Upload

Affects SurveyJS (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 9.9 Critical : upgrade to 1.9.137 as a priority.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
9.9Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.0% chance of exploitation in 30 days – higher than 63% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.9.137
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Oct 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade devsoftbaltic/surveyjs to 1.9.137.

Affected software

ProductAffectedFixed in
npmdevsoftbaltic/surveyjspkg:npm/devsoftbaltic/surveyjsOther threatsAffected
  • <1.9.137
Fixed in
  • 1.9.137

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, restrict file upload permissions, implement manual file type validation, or disable file uploads if possible to reduce risk.

Description

Unrestricted Upload of File with Dangerous Type vulnerability in devsoftbaltic SurveyJS surveyjs.This issue affects SurveyJS: from n/a through <= 1.9.136.

References

Community reviews

Loading reviews…