Skip to main content
VulnerabilityPublished

CVE-2024-5139: WSO2 Enterprise Integrator · Cross-site Scripting

Affects WSO2 Enterprise IntegratorSource CVE Database V5

0

Not known to be exploited · CVSS 6.1 Medium : upgrade to 6.6.0.204 when convenient.

Data as of 26 Oct 2026, 15:59 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.6.0.204, 7.0.0.64, 6.1.0.195 +22
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
WSO2WSO2 Enterprise IntegratorAffected
  • >=6.6.0 <6.6.0.204
Fixed in
  • 6.6.0.204
WSO2WSO2 Identity ServerAffected
  • >=7.0.0 <7.0.0.64
Fixed in
  • 7.0.0.64
WSO2WSO2 Identity ServerAffected
  • >=6.1.0 <6.1.0.195
Fixed in
  • 6.1.0.195
WSO2WSO2 Identity ServerAffected
  • >=6.0.0 <6.0.0.212
Fixed in
  • 6.0.0.212
WSO2WSO2 Identity ServerAffected
  • >=5.10.0 <5.10.0.310
Fixed in
  • 5.10.0.310
WSO2WSO2 API ManagerAffected
  • >=4.3.0 <4.3.0.6
Fixed in
  • 4.3.0.6

AI-suggested

A fix is available in versions beyond the specified upper bounds in the affectedVersions list. Users should upgrade to versions at or beyond these fixed releases to remediate the vulnerability. No additional mitigation steps are indicated or necessary according to the provided data.

Description

The Authentication Endpoint accepts user-supplied input without sufficient encoding, allowing for the injection of malicious JavaScript payloads. This vulnerability can be triggered by submitting crafted input to the Authentication Endpoint. Successful exploitation allows an attacker to redirect the user's browser to a malicious website, modify the web page's user interface, or extract sensitive information from the browser. However, due to the `httpOnly` flag on session-related cookies, session hijacking is not possible.

References

Community reviews

Loading reviews…