Skip to main content
VulnerabilityPublished

CVE-2024-7075: WSO2 Enterprise Integrator · Cross-site Scripting

Affects WSO2 Enterprise IntegratorSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.6 Medium : upgrade to 6.6.0.212 when convenient.

Data as of 2 Nov 2026, 09:43 UTC

CVSS 3.1 base score
4.6Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (WSO2)CVSS 3.14.6
Patch
Available – fixed in 6.6.0.212, 4.4.0.2, 4.3.0.36 +20
CVSS:3.1/AV:A/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
WSO2WSO2 Enterprise IntegratorAffected
  • >=6.6.0 <6.6.0.212
Fixed in
  • 6.6.0.212
WSO2WSO2 API ManagerAffected
  • >=4.4.0 <4.4.0.2
Fixed in
  • 4.4.0.2
WSO2WSO2 API ManagerAffected
  • >=4.3.0 <4.3.0.36
Fixed in
  • 4.3.0.36
WSO2WSO2 API ManagerAffected
  • >=4.2.0 <4.2.0.125
Fixed in
  • 4.2.0.125
WSO2WSO2 API ManagerAffected
  • >=4.1.0 <4.1.0.186
Fixed in
  • 4.1.0.186
WSO2WSO2 API ManagerAffected
  • >=4.0.0 <4.0.0.325
Fixed in
  • 4.0.0.325

AI-suggested

Fixed versions are available and users should upgrade to the following releases or later: 3.2.0.388, 3.2.1.31, 4.0.0.325, 4.1.0.186, 4.2.0.125, 4.3.0.36, 4.4.0.2, 6.1.0.187, 6.6.0.212, and 7.0.0.60. Applying these updates will remediate the vulnerability. No additional mitigation steps are indicated by the vendor advisory.

Description

CVE-2024-7075 is a cross-site scripting (XSS) vulnerability in the user search function of the WSO2 Enterprise Integrator management console. The flaw allows attackers to inject malicious scripts that execute in the context of the console, potentially redirecting users, modifying the UI, or extracting browser information. The vulnerability does not allow session hijacking due to the httpOnly flag on session cookies. Multiple versions prior to fixed releases are affected.

References

Community reviews

Loading reviews…