Skip to main content
VulnerabilityPublished Updated

CVE-2025-6623: WSO2 API Manager · Cross-site Scripting

Affects WSO2 API ManagerSource CVE Database V5

0

Not known to be exploited · CVSS 4.3 Medium · fixed in 4.5.0.11 : update WSO2 API Manager when convenient.

Data as of 26 Oct 2026, 22:14 UTC

CVSS 3.1 base score
4.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.5.0.11, 4.4.0.29, 4.3.0.66 +12
CVSS:3.1/AV:A/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
WSO2WSO2 API ManagerAffected
  • >=4.5.0 <4.5.0.11
Fixed in
  • 4.5.0.11
WSO2WSO2 API ManagerAffected
  • >=4.4.0 <4.4.0.29
Fixed in
  • 4.4.0.29
WSO2WSO2 API ManagerAffected
  • >=4.3.0 <4.3.0.66
Fixed in
  • 4.3.0.66
WSO2WSO2 API ManagerAffected
  • >=4.2.0 <4.2.0.153
Fixed in
  • 4.2.0.153
WSO2WSO2 API ManagerAffected
  • >=4.1.0 <4.1.0.215
Fixed in
  • 4.1.0.215
WSO2WSO2 API ManagerAffected
  • >=3.2.1 <3.2.1.53
Fixed in
  • 3.2.1.53

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Fixed versions addressing this vulnerability have been released. Users should upgrade to the fixed versions listed: 3.2.0.433, 3.2.1.53, 4.1.0.215, 4.2.0.153, 4.3.0.66, 4.4.0.29, 4.5.0.11, 4.5.0.12, 5.3.15.3, and 5.3.20.1. Applying these official fixes will remediate the vulnerability. No additional mitigation is required if these updates are applied.

Description

CVE-2025-6623 is a cross-site scripting (XSS) vulnerability in the WSO2 API Manager's carbon console. The vulnerability arises because user-supplied XML input is not properly encoded, allowing injection of malicious scripts. Exploitation enables remote attackers to execute arbitrary JavaScript in the victim's browser context, potentially redirecting users or modifying the web page interface. Session hijacking is mitigated by the httpOnly flag on session cookies. Multiple versions prior to specific fixed releases are affected.

References

Community reviews

Loading reviews…