Skip to main content
VulnerabilityPublished

CVE-2026-11854: WSO2 API Manager · Cross-site Scripting

Affects WSO2 API ManagerSource CVE Database V5

0

Not known to be exploited · CVSS 6.1 Medium · fixed in 4.7.0.1 : update WSO2 API Manager when convenient.

Data as of 28 Oct 2026, 20:45 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.7.0.1, 4.6.0.29, 4.5.0.65 +15
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
WSO2WSO2 API ManagerAffected
  • >=4.7.0 <4.7.0.1
Fixed in
  • 4.7.0.1
WSO2WSO2 API ManagerAffected
  • >=4.6.0 <4.6.0.29
Fixed in
  • 4.6.0.29
WSO2WSO2 API ManagerAffected
  • >=4.5.0 <4.5.0.65
Fixed in
  • 4.5.0.65
WSO2WSO2 API ManagerAffected
  • >=4.4.0 <4.4.0.80
Fixed in
  • 4.4.0.80
WSO2WSO2 API ManagerAffected
  • >=4.3.0 <4.3.0.117
Fixed in
  • 4.3.0.117
WSO2WSO2 API ManagerAffected
  • >=4.2.0 <4.2.0.205
Fixed in
  • 4.2.0.205

AI-suggested

Fixed versions are available and should be applied to remediate this vulnerability. The fixed releases include 3.2.0.480, 3.2.1.99, 4.1.0.265, 4.2.0.205, 4.3.0.117, 4.4.0.80, 4.5.0.65, 4.6.0.29, 4.6.0.30, and 4.7.0.1. Users should upgrade to these or later versions to mitigate the risk. No additional vendor advisory indicates alternative mitigations or that no action is required.

Description

CVE-2026-11854 is a cross-site scripting (XSS) vulnerability in the authentication endpoint of WSO2 API Manager. The endpoint reflects unsanitized user input in error messages, allowing attackers to inject malicious scripts. Exploitation can lead to actions executed in the victim's browser, such as UI manipulation or redirection to malicious sites. However, session hijacking is mitigated by the httpOnly flag on session cookies.

References

Community reviews

Loading reviews…