Skip to main content
VulnerabilityPublished Updated

CVE-2024-5150: OTP Login With Phone Number, OTP Verification (WordPress plugin) · Authentication Bypass Using an Alternate Path or Channel

Affects OTP Login With Phone Number, OTP Verification (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 9.8 Critical · fixed in 1.7.26 : patch OTP Login With Phone Number, OTP Verification (WordPress plugin) as a priority.

Data as of 26 Oct 2026, 11:42 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.8% chance of exploitation in 30 days – higher than 56% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.7.26
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 May 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
glboy OTP Login With Phone Number, OTP VerificationAffected
  • =0
Fixed in–

AI-suggested

Upgrade the plugin to version 1.7.27 or later, where the vulnerability is fully fixed. The patch in version 1.7.26 is incomplete and causes functional issues, so version 1.7.27 should be used. No other mitigations are indicated by the vendor advisory. Patch status is confirmed by the plugin version history and advisory details.

Description

The Login with phone number plugin for WordPress is vulnerable to authentication bypass in versions up to, and including, 1.7.26. This is due to the 'activation_code' default value is empty, and the not empty check is missing in the 'lwp_ajax_register' function. This makes it possible for unauthenticated attackers to log in as any existing user on the site, such as an administrator, if they have access to the user email. The vulnerability is patched in version 1.7.26, but there is an issue in the patch that causes the entire function to not work, and this issue is fixed in version 1.7.27.

References

Community reviews

Loading reviews…