Skip to main content
VulnerabilityPublished

CVE-2024-54011: Hanwha Vision QND-8080R · Improper Input Validation

Affects Hanwha Vision QND-8080RSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium : upgrade to 2.24.00 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.24.00
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Hanwha Vision QND-8080R to 2.24.00.

Affected software

ProductAffectedFixed in
Hanwha VisionQND-8080RAffected
  • <2.24.00
Fixed in
  • 2.24.00

AI-suggested

The manufacturer has released patch firmware to address this vulnerability. Users and administrators should apply the official firmware update from Hanwha Vision as soon as it is available. Patch status is not explicitly confirmed in the provided data; therefore, verify the vendor advisory for the latest remediation instructions and firmware downloads. No additional mitigation recommendations are provided or required based on the available information.

Description

CVE-2024-54011 is a medium severity vulnerability in the Hanwha Vision QND-8080R camera system caused by improper input validation. This flaw can lead to service disruption when the device processes certain crafted requests. The vulnerability was discovered by penetration testers at Amazon. The manufacturer has released patch firmware addressing this issue, though specific patch details were not provided in the input data. No known exploits in the wild have been reported. The vulnerability has a CVSS 4.0 base score of 5.3, indicating a moderate impact primarily due to service disruption without elevated privileges or user interaction required.

References

Community reviews

Loading reviews…