CVE-2024-5594: OpenVPN · Improper Validation of Specified Type of Input
Affects OpenVPNSource GCVE Database
Not known to be exploited · CVSS 9.1 Critical : upgrade to 2.6.11 as a priority.
Data as of 30 Oct 2026, 00:29 UTC
Thin evidence
One scorer or none| CISA-ADP | CVSS 3.1 | 9.1 |
|---|
- Patch
- Available – fixed in 2.6.11
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Jan 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade OpenVPN to 2.6.11.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| OpenVPN OpenVPN | Affected
| Fixed in
|
AI-suggested
A fix is available in OpenVPN version 2.6.11 and later. Users should upgrade to version 2.6.11 or newer to remediate this vulnerability.
Description
CVE-2024-5594 is a critical vulnerability in OpenVPN versions before 2.6.11 where the client does not properly sanitize PUSH_REPLY messages from the server. This flaw allows a malicious server to inject arbitrary data into client logs, potentially leading to information disclosure or log manipulation.