Skip to main content
VulnerabilityPublished Updated

CVE-2024-58367: surrealdb · Improper Authorization

Affects surrealdbSource GCVE Database

0

Not known to be exploited · CVSS 7.1 High · fixed in 2.0.4 : patch surrealdb soon.

Data as of 27 Oct 2026, 20:28 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.0.4
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
surrealdb surrealdbAffected
  • =0
Fixed in–

AI-suggested

A fix is available in SurrealDB version 2.0.4 and later. Users should upgrade to version 2.0.4 or above to remediate this vulnerability. Until upgraded, users should restrict database access to trusted users only.

Description

SurrealDB versions before 2.0.4 have an improper authorization vulnerability that allows authorized users to bypass field-level permissions during SELECT, UPDATE, and DELETE operations. Attackers can use various query techniques to access protected field values without having explicit SELECT permissions. This flaw affects version 0 and is rated high severity with a CVSS score of 7.1.

References

Community reviews

Loading reviews…