Skip to main content
VulnerabilityPublished Updated

CVE-2024-58370: surrealdb · Uncontrolled Recursion

Affects surrealdbSource GCVE Database

0

Not known to be exploited · CVSS 7.1 High : upgrade to 1.1.0 soon.

Data as of 27 Oct 2026, 20:28 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.1.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade surrealdb to 1.1.0.

Affected software

ProductAffectedFixed in
surrealdb surrealdbAffected
  • <1.1.0
Fixed in
  • 1.1.0

AI-suggested

Users should upgrade to SurrealDB version 1.1.0 or later once available, as the vulnerability affects versions before 1.1.0. If you cannot patch yet, restrict query complexity and nesting depth where possible and monitor for abnormal query patterns.

Description

SurrealDB versions before 1.1.0 have a vulnerability where recursion depth limits are not enforced when parsing nested SurrealQL statements. This allows authorized attackers to submit queries with excessive nesting, causing a stack overflow and crashing the server.

References

Community reviews

Loading reviews…